In code, and particularly with regard to classes, plural object names are best reserved for collections, such as the Access collection. Singular objects are therefore named in the singular, as with the TableDef object. This strategy unambiguously describes the actual state of the object.

Many people apply a plural naming convention to tables. Although this may make some sense in terms of the fact that tables can contain many records, my preference is to use the singular, for example, tblAddress and tblPerson. This is just personal preference; you can use plural if you like; just be consistent.

Except in the case of collections, applying plural names to some objects and singular to others of the same type is a definite no-no. Consistency is important, as object names are sometimes all a programmer has to determine the purpose and function of objects in the applications you create.

0 0

Post a comment